Installing ab-initio calculators on debian

Installation of elk all-electron full-potential linearised augmented-plane wave (FP-LAPW) as easy as;
“aptitude search elk”
“aptitude install elk-lapw”

Installation of quantum espresso, computer codes for density-functional theory using plane waves, and pseudopotentials, as easy as;
“aptitude install quantum-espresso”

Installation of xrysden
“aptitude install xcrysden”

 


root>
aptitude install elk-lapw
The following NEW packages will be installed:
elk-lapw libcr0{a} libhwloc-plugins{a} libhwloc5{a} libibverbs1{a} libnuma1{a} libopenmpi1.6{a} libxc1{a} ocl-icd-libopencl1{a}
0 packages upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 4025 kB of archives. After unpacking 12.6 MB will be used.
Do you want to continue? [Y/n/?] y
Get: 1 http://ftp.uk.debian.org/debian/ jessie/main libnuma1 amd64 2.0.10-1 [32.5 kB]
Get: 2 http://ftp.uk.debian.org/debian/ jessie/main libhwloc5 amd64 1.10.0-3 [86.9 kB]
Get: 3 http://ftp.uk.debian.org/debian/ jessie/main ocl-icd-libopencl1 amd64 2.2.3-1+deb8u1 [33.6 kB]
Get: 4 http://ftp.uk.debian.org/debian/ jessie/main libcr0 amd64 0.8.5-2.2 [32.7 kB]
Get: 5 http://ftp.uk.debian.org/debian/ jessie/main libibverbs1 amd64 1.1.8-1.1 [32.2 kB]
Get: 6 http://ftp.uk.debian.org/debian/ jessie/main libopenmpi1.6 amd64 1.6.5-9.1 [1460 kB]
Get: 7 http://ftp.uk.debian.org/debian/ jessie/main libxc1 amd64 2.1.1-1 [284 kB]
Get: 8 http://ftp.uk.debian.org/debian/ jessie/main elk-lapw amd64 2.3.22-1 [2048 kB]
Get: 9 http://ftp.uk.debian.org/debian/ jessie/main libhwloc-plugins amd64 1.10.0-3 [15.2 kB]
Fetched 4025 kB in 5s (750 kB/s)
Selecting previously unselected package libnuma1:amd64.
(Reading database ... 209260 files and directories currently installed.)
Preparing to unpack .../libnuma1_2.0.10-1_amd64.deb ...
Unpacking libnuma1:amd64 (2.0.10-1) ...
Selecting previously unselected package libhwloc5:amd64.
Preparing to unpack .../libhwloc5_1.10.0-3_amd64.deb ...
Unpacking libhwloc5:amd64 (1.10.0-3) ...
Selecting previously unselected package ocl-icd-libopencl1:amd64.
Preparing to unpack .../ocl-icd-libopencl1_2.2.3-1+deb8u1_amd64.deb ...
Unpacking ocl-icd-libopencl1:amd64 (2.2.3-1+deb8u1) ...
Selecting previously unselected package libcr0.
Preparing to unpack .../libcr0_0.8.5-2.2_amd64.deb ...
Unpacking libcr0 (0.8.5-2.2) ...
Selecting previously unselected package libibverbs1.
Preparing to unpack .../libibverbs1_1.1.8-1.1_amd64.deb ...
Unpacking libibverbs1 (1.1.8-1.1) ...
Selecting previously unselected package libopenmpi1.6.
Preparing to unpack .../libopenmpi1.6_1.6.5-9.1_amd64.deb ...
Unpacking libopenmpi1.6 (1.6.5-9.1) ...
Selecting previously unselected package libxc1:amd64.
Preparing to unpack .../libxc1_2.1.1-1_amd64.deb ...
Unpacking libxc1:amd64 (2.1.1-1) ...
Selecting previously unselected package elk-lapw.
Preparing to unpack .../elk-lapw_2.3.22-1_amd64.deb ...
Unpacking elk-lapw (2.3.22-1) ...
Selecting previously unselected package libhwloc-plugins.
Preparing to unpack .../libhwloc-plugins_1.10.0-3_amd64.deb ...
Unpacking libhwloc-plugins (1.10.0-3) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up libnuma1:amd64 (2.0.10-1) ...
Setting up libhwloc5:amd64 (1.10.0-3) ...
Setting up ocl-icd-libopencl1:amd64 (2.2.3-1+deb8u1) ...
Setting up libcr0 (0.8.5-2.2) ...
Setting up libibverbs1 (1.1.8-1.1) ...
Setting up libopenmpi1.6 (1.6.5-9.1) ...
Setting up libxc1:amd64 (2.1.1-1) ...
Setting up elk-lapw (2.3.22-1) ...
Setting up libhwloc-plugins (1.10.0-3) ...
Processing triggers for libc-bin (2.19-18+deb8u4) ...

root@ptlin10:~# aptitude install quantum-espresso
The following NEW packages will be installed:
libblacs-openmpi1{a} libelpa0{a} libscalapack-openmpi1{a} mpi-default-bin{a} openmpi-bin{a} openmpi-common{a} quantum-espresso
quantum-espresso-data{a}
0 packages upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 23.8 MB of archives. After unpacking 134 MB will be used.
Do you want to continue? [Y/n/?] y
Get: 1 http://ftp.uk.debian.org/debian/ jessie/main libelpa0 amd64 2013.11.008-2 [88.9 kB]
Get: 2 http://ftp.uk.debian.org/debian/ jessie/main openmpi-common all 1.6.5-9.1 [110 kB]
Get: 3 http://ftp.uk.debian.org/debian/ jessie/main openmpi-bin amd64 1.6.5-9.1 [154 kB]
Get: 4 http://ftp.uk.debian.org/debian/ jessie/main mpi-default-bin amd64 1.0.2+nmu2 [3356 B]
Get: 5 http://ftp.uk.debian.org/debian/ jessie/main libblacs-openmpi1 amd64 1.1-33 [56.8 kB]
Get: 6 http://ftp.uk.debian.org/debian/ jessie/main libscalapack-openmpi1 amd64 1.8.0-12 [2184 kB]
Get: 7 http://ftp.uk.debian.org/debian/ jessie/main quantum-espresso amd64 5.1+dfsg-3 [10.1 MB]
Get: 8 http://ftp.uk.debian.org/debian/ jessie/main quantum-espresso-data all 5.1+dfsg-3 [11.1 MB]
Fetched 23.8 MB in 30s (774 kB/s)
Selecting previously unselected package libelpa0.
(Reading database ... 209802 files and directories currently installed.)
Preparing to unpack .../libelpa0_2013.11.008-2_amd64.deb ...
Unpacking libelpa0 (2013.11.008-2) ...
Selecting previously unselected package openmpi-common.
Preparing to unpack .../openmpi-common_1.6.5-9.1_all.deb ...
Unpacking openmpi-common (1.6.5-9.1) ...
Selecting previously unselected package openmpi-bin.
Preparing to unpack .../openmpi-bin_1.6.5-9.1_amd64.deb ...
Unpacking openmpi-bin (1.6.5-9.1) ...
Selecting previously unselected package mpi-default-bin.
Preparing to unpack .../mpi-default-bin_1.0.2+nmu2_amd64.deb ...
Unpacking mpi-default-bin (1.0.2+nmu2) ...
Selecting previously unselected package libblacs-openmpi1.
Preparing to unpack .../libblacs-openmpi1_1.1-33_amd64.deb ...
Unpacking libblacs-openmpi1 (1.1-33) ...
Selecting previously unselected package libscalapack-openmpi1.
Preparing to unpack .../libscalapack-openmpi1_1.8.0-12_amd64.deb ...
Unpacking libscalapack-openmpi1 (1.8.0-12) ...
Selecting previously unselected package quantum-espresso.
Preparing to unpack .../quantum-espresso_5.1+dfsg-3_amd64.deb ...
Unpacking quantum-espresso (5.1+dfsg-3) ...
Selecting previously unselected package quantum-espresso-data.
Preparing to unpack .../quantum-espresso-data_5.1+dfsg-3_all.deb ...
Unpacking quantum-espresso-data (5.1+dfsg-3) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up libelpa0 (2013.11.008-2) ...
Setting up openmpi-common (1.6.5-9.1) ...
Setting up openmpi-bin (1.6.5-9.1) ...
update-alternatives: using /usr/bin/mpirun.openmpi to provide /usr/bin/mpirun (mpirun) in auto mode
Setting up mpi-default-bin (1.0.2+nmu2) ...
Setting up libblacs-openmpi1 (1.1-33) ...
Setting up libscalapack-openmpi1 (1.8.0-12) ...
Setting up quantum-espresso (5.1+dfsg-3) ...
Setting up quantum-espresso-data (5.1+dfsg-3) ...
Processing triggers for libc-bin (2.19-18+deb8u4) ...

root>>aptitude install xcrysden
The following NEW packages will be installed:
bwidget{a} libgl2ps0{a} libopenbabel4{a} openbabel{a} xcrysden xcrysden-data{a}
0 packages upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 5387 kB of archives. After unpacking 19.4 MB will be used.
Do you want to continue? [Y/n/?] y
Get: 1 http://ftp.uk.debian.org/debian/ jessie/main bwidget all 1.9.8-1 [194 kB]
Get: 2 http://ftp.uk.debian.org/debian/ jessie/main libgl2ps0 amd64 1.3.8-1.2 [35.4 kB]
Get: 3 http://ftp.uk.debian.org/debian/ jessie/main libopenbabel4 amd64 2.3.2+dfsg-2 [2913 kB]
Get: 4 http://ftp.uk.debian.org/debian/ jessie/main openbabel amd64 2.3.2+dfsg-2 [254 kB]
Get: 5 http://ftp.uk.debian.org/debian/ jessie/main xcrysden-data all 1.5.60-1 [1603 kB]
Get: 6 http://ftp.uk.debian.org/debian/ jessie/main xcrysden amd64 1.5.60-1 [387 kB]
Fetched 5387 kB in 10s (518 kB/s)
Selecting previously unselected package bwidget.
(Reading database ... 210350 files and directories currently installed.)
Preparing to unpack .../bwidget_1.9.8-1_all.deb ...
Unpacking bwidget (1.9.8-1) ...
Selecting previously unselected package libgl2ps0.
Preparing to unpack .../libgl2ps0_1.3.8-1.2_amd64.deb ...
Unpacking libgl2ps0 (1.3.8-1.2) ...
Selecting previously unselected package libopenbabel4.
Preparing to unpack .../libopenbabel4_2.3.2+dfsg-2_amd64.deb ...
Unpacking libopenbabel4 (2.3.2+dfsg-2) ...
Selecting previously unselected package openbabel.
Preparing to unpack .../openbabel_2.3.2+dfsg-2_amd64.deb ...
Unpacking openbabel (2.3.2+dfsg-2) ...
Selecting previously unselected package xcrysden-data.
Preparing to unpack .../xcrysden-data_1.5.60-1_all.deb ...
Unpacking xcrysden-data (1.5.60-1) ...
Selecting previously unselected package xcrysden.
Preparing to unpack .../xcrysden_1.5.60-1_amd64.deb ...
Unpacking xcrysden (1.5.60-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for gnome-menus (3.13.3-6) ...
Processing triggers for mime-support (3.58) ...
Setting up bwidget (1.9.8-1) ...
Setting up libgl2ps0 (1.3.8-1.2) ...
Setting up libopenbabel4 (2.3.2+dfsg-2) ...
Setting up openbabel (2.3.2+dfsg-2) ...
Setting up xcrysden-data (1.5.60-1) ...
Setting up xcrysden (1.5.60-1) ...
Processing triggers for libc-bin (2.19-18+deb8u4) ...

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: